Xpdf-libpoppler StreamPredictor Exploit

This module exploits a integer overflow vulnerability in the xpdf and libpoppler software included in most linux distributions. The vulnerability is caused by a integer overflow in the predictor calculation, which causes a buffer overflow in the stack of the StreamPredictor::getNextLine() function. The exploit is triggered when an unsuspecting user opens a specially crafted file distributed via an email.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2007-3387
Product Version: 
7
Released Date: 
Friday, September 21, 2007 - 00:00