Wordpress Password Reset Exploit

A weakness has been reported in WordPress which can be exploited to bypass certain security restrictions. The weakness is due to a bug within the password reset functionality when verifying the secret key. This can be exploited to reset the password of the first user without a key in the database (usually administrator) without providing the correct secret key.
Vulnerabilty ID: 
NOCVE-9999-39525
Released Date: 
Thursday, August 27, 2009 - 19:00