VLC Media Player SMB URI Handling Buffer Overflow Exploit

VLC Media Player is prone to a stack-based buffer-overflow vulnerability when handling playlist files having an overly long SMB URI.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2009-2484
Product Version: 
9.0
Released Date: 
Wednesday, July 22, 2009 - 00:00