vBulletin query Cross Site Scripting Exploit

The application is prone to a cross-site scripting vulnerability because it fails to sufficiently sanitize user-supplied input to the 'query' parameter of the search pages. An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may let the attacker steal cookie-based authentication credentials and launch other attacks. vBulletin 4.0.2 is vulnerable. This issue does not affect vBulletin 3.x versions.
Platform: 
Vulnerabilty ID: 
NOCVE-9999-42681
Product Version: 
10.0
Released Date: 
Tuesday, April 20, 2010 - 00:00