TP-Link Camera Unauthenticated Remote Firmware Upgrade Exploit

The /cgi-bin/firmwareupgrade file in TP-Link IP cameras allows remote unauthenticated attackers to perform firmware upgrades. This module tries to verify if the vulnerability is present in the target device without actually upgrading its firmware.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2013-2581
Product Version: 
2013_R2
Released Date: 
Friday, December 13, 2013 - 00:00