Sun Java RMIConnectionImpl Deserialization Privilege Escalation Exploit

This module exploits a privilege escalation vulnerability in Sun Java. The specific flaw exists within the deserialization of RMIConnectionImpl objects. Due to a lack of privilege checks during deserialization it is possible to supply privileged code in the ClassLoader of a constructor being deserialized. This allows for a remote attacker to call system level Java functions without proper sandboxing. Exploitation of this can lead to remote system compromise under the context of the currently logged in user.
Exploit type: 
Vulnerabilty ID: 
CVE-2010-0094
Product Version: 
11.0
Released Date: 
Friday, June 24, 2011 - 00:00