Soulseek Server Peer Search Buffer Overflow Exploit

The application is prone to a stack-based buffer-overflow vulnerability that occurs because it fails to perform adequate boundary checks on user-supplied data. Specifically, this issue occurs when performing a direct peer file search.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2009-1830
Product Version: 
9.0
Released Date: 
Tuesday, July 21, 2009 - 00:00