Procyon Core Server HMI Scada Coreservice Buffer Overflow Exploit Update

Vulnerability in the coreservice.exe component of Procyon Core Server versions 1.13 and below. While processing a password, the application fails to do proper bounds checking before copying data into a buffer on the stack. This causes a buffer overflow and allows it to overwrite a structured exception handling record, allowing for unauthenticated remote code execution. This version updates runtime value to the appropriate for this case.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2011-3322
Product Version: 
2013 R1
Released Date: 
Monday, March 4, 2013 - 00:00