PHP apache_request_headers Function Buffer Overflow Exploit

This module exploits a buffer overflow in PHP. The specific flaw is in the apache_request_handlers() function. The apache_request_handlers() function fails to validate the length of certain headers in the HTTP request and blindly copy all the string received in the vulnerable header to the stack causing a buffer overflow.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2012-2329
Product Version: 
12.5
Released Date: 
Monday, October 1, 2012 - 00:00