Orbit Downloader Download Failed Exploit

Orbit Downloader is vulnerable to a buffer overflow attack, which can be exploited by malicious remote attackers to execute arbitrary code. The vulnerability is due to Orbit not properly converting an URL ASCII string to UNICODE. This can be exploited to execute arbitrary code by downloading a file from a specially crafted URL.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2008-1602
Product Version: 
7.5
Released Date: 
Friday, May 9, 2008 - 00:00