Oracle Java AtomicReferenceArray Type Confusion Exploit

Unsafe type handling performed by the AtomicReferenceArray class of the Oracle Java Runtime Environment can be abused to cause a type confusion error. This flaw allows an unprivileged Java applet to escape the sandbox and execute arbitrary code on the target machine with the privileges of the current user.
Exploit type: 
Vulnerabilty ID: 
CVE-2012-0507
Product Version: 
12.0
Released Date: 
Monday, March 26, 2012 - 00:00