OpenSSL TLS Heartbeat Read Overrun Memory Disclosure Exploit Update

A missing boundary check in the TLS Heartbeat extension in OpenSSL can be abused by remote attackers to read up to 64 kb of memory from the server. This memory disclosure vulnerability can be used by remote unauthenticated attackers to obtain sensitive information from the affected server, including private keys and session cookies. This update adds features to the module, like the ability to read 64 kb of data from vulnerable services, reporting the results in the Module Output window, and saving the memory dumps to disk. It also improves the compatibility with OpenSSL services and adds support for FTPS.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2014-0160
Product Version: 
2014_R1
Released Date: 
Friday, September 5, 2014 - 00:00