OpenSite 2.1 Weak Authentication Exploit

This module exploits an authentication vulnerability in OpenSite 2.1. The function init in origin/libs/user.php checks for a matching origin_hash cookie. However, this cookie can be bruteforced in at most 2^32 tries for a known username. Actually, the number of attempts could be significantly reduced knowing that we do not have to check for time in the future, and long past. This works for OpenSite 2.1 and below.
Platform: 
Vulnerabilty ID: 
NOCVE-9999-36572
Product Version: 
8.0
Released Date: 
Tuesday, April 14, 2009 - 00:00