Mac OS X smcFanControl Local Privilege Escalation Exploit

This module exploits a buffer overflow vulnerability in smcFanControl on Apple Mac OS X 10.4.x when the software is installed with setuid root. An attacker can exploit this vulnerability to obtain root privileges.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2008-6252
Product Version: 
7.6
Released Date: 
Monday, December 29, 2008 - 00:00