Linux Overlayfs ovl_setattr Local Privilege Escalation Exploit

This module exploits a vulnerability in Linux. The ovl_setattr function in fs/overlayfs/inode.c in the Linux kernel through 4.3.3 attempts to merge distinct setattr operations, which allows local users to bypass intended access restrictions and modify the attributes of arbitrary overlay files via a crafted application.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2015-8660
Product Version: 
2015_R1
Released Date: 
Friday, January 8, 2016 - 00:00