Linux Overlayfs Local Privilege Escalation Exploit

This module exploits a vulnerability in Linux. The overlayfs filesystem does not correctly check file permissions when creating new files in the upper filesystem directory. This can be exploited by an unprivileged process in kernels with CONFIG_USER_NS=y and where overlayfs has the FS_USERNS_MOUNT flag, which allows the mounting of overlayfs inside unprivileged mount namespaces.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2015-1328
Product Version: 
2014_R2
Released Date: 
Friday, June 19, 2015 - 00:00