Linux Kernel udp_sendmsg Privilege Escalation Exploit

This module exploits a vulnerability in the udp_sendmsg function in the UDP implementation in net/ipv4/udp.c and net/ipv6/udp.c in the Linux kernel before 2.6.19 allowing local users to gain privileges via vectors involving the MSG_MORE flag and a UDP socket.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2009-2698
Product Version: 
10.5
Released Date: 
Monday, August 2, 2010 - 00:00