Linux Kernel n_tty_write Privilege Escalation Exploit Update

This module exploits a vulnerability in the Linux Kernel. The n_tty_write function in drivers/tty/n_tty.c in the Linux kernel through 3.14.3 does not properly manage tty driver access in the "LECHO & !OPOST" case, which allows local attackers to escalate privileges triggering a race condition involving read and write operations with long strings. This update adds support for Ubuntu 14.04.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2014-0196
Product Version: 
2014_R2
Released Date: 
Wednesday, October 15, 2014 - 00:00