Linux Kernel libfutex Privilege Escalation Exploit

This module exploits a vulnerability in the Linux Kernel. The futex_requeue function in kernel/futex.c in the Linux kernel does not ensure that calls have two different futex addresses, which allows local attackers to gain privileges via a crafted FUTEX_REQUEUE command.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2014-3153
Product Version: 
2014_R2
Released Date: 
Thursday, December 4, 2014 - 00:00