Iconics Genesis 32 WebHMI ActiveX Stack Overflow Exploit

This module exploits a vulnerability in the GenVersion.dll module included in the Iconics Genesis 32 application. The exploit is triggered when the SetActiveXGUID() method processes a malformed argument resulting in a memory corruption.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2011-2089
Product Version: 
11.0
Released Date: 
Thursday, May 5, 2011 - 00:00