HP OpenView NNM ovalarm CGI Remote Buffer Overflow Exploit

This module exploits a buffer overflow vulnerability in the ovalarm.exe application, part of the HP OpenView Network Node Manager application. The exploit triggers a stack-based buffer overflow by sending a specially crafted HTTP request to the ports 3443/TCP or 80/TCP of the vulnerable system and installs an agent if successful.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2009-4179
Product Version: 
10.0
Released Date: 
Monday, December 28, 2009 - 00:00