Goodtech Telnet Daemon Buffer Overflow Exploit

There is a buffer overflow vulnerability in the administration web server for GoodTech Telnet Server which allows remote attackers to execute arbitrary code via a long string to port 2380.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2005-0768
Product Version: 
12.0
Released Date: 
Wednesday, January 25, 2012 - 00:00