GNOME Dia PySys_SetArgv Remote Command Execution Exploit

A design error has been discovered in GNOME's Dia, which can be exploited by sending a malicious file to vulnerable victims.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2008-5984
Product Version: 
8.0
Released Date: 
Wednesday, May 6, 2009 - 00:00