FreeBSD mount Local Privilege Escalation Exploit Update

FreeBSD is prone to multiple stack-based buffer-overflow vulnerabilities because the kernel fails to perform adequate boundary checks on user-supplied data. If the system is configured to allow unprivileged users to mount file systems, it is possible for a local adversary to exploit this vulnerability and execute code in the context of the kernel. This update fixs some issues and adds validations pre-explotation.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2008-3531
Product Version: 
10.5
Released Date: 
Monday, July 19, 2010 - 00:00