Firebird SQL Remote Buffer Overflow Exploit

This module exploits a buffer overflow vulnerability in the database service (fbserver.exe) of the FireBird SQL application. The exploit triggers a stack-based buffer overflow by sending a specially crafted "create" request to port 3050/TCP of the vulnerable system and installs an agent if successful.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2007-3566
Product Version: 
7
Released Date: 
Tuesday, September 11, 2007 - 00:00