FCKeditor CurrentFolder Parameter Arbitrary File Upload Exploit

FCKeditor is prone to an arbitrary-file-upload vulnerability because it fails to adequately sanitize user-supplied input. An attacker can exploit this vulnerability to upload arbitrary code and execute it in the context of the webserver process. This may facilitate unauthorized access or privilege escalation; other attacks are also possible. WARNING: This is an early release module. This is not the final version of this module. It is a pre-released version in order to deliver a module as quickly as possible to our customers that may be useful in some situations. Since this module is not the final version it may contain bugs or have limited functionality and may not have complete or accurate documentation.
Platform: 
Vulnerabilty ID: 
CVE-2009-2265
Product Version: 
8.0
Released Date: 
Tuesday, July 7, 2009 - 00:00