Diamond Programmer XCF File Processing Buffer Overflow Exploit

Diamond Programmer is prone to a buffer-overflow when handling specially crafted XCF files with an overly long string.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2012-2614
Product Version: 
12.3
Released Date: 
Thursday, June 21, 2012 - 00:00