Belkin BullDog Plus UPS-Service Buffer Overflow Exploit

The UPS management software contains a built-in web server which allows for remote management of the UPS. The management interface is protected by a username and password and the authentication is performed via Basic authentication. There is a small stack-based overflow in the base64 decoding routine which handles the Basic authentication data.
Exploit type: 
Platform: 
Vulnerabilty ID: 
NOCVE-9999-37026
Product Version: 
8.0
Released Date: 
Thursday, April 30, 2009 - 00:00