Awingsoft Awakening Remote Command Execution Exploit

Awingsoft Awakening (aka Winds3D) Viewer, which runs as a plugin within most popular web browsers, is vulnerable to a remotely exploitable arbitrary command execution vulnerability which can be triggered by making the user visit a malicious link/website.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2009-2386
Product Version: 
9.0
Released Date: 
Thursday, August 27, 2009 - 00:00