Apple Mac OS X Samba NetWkstaTransportEnum Request Remote Buffer Overflow Exploit Update

This module exploits a vulnerability in Mac OS X Samba server. When a specially crafted call to "NetWkstaTransportEnum" RPC function is processed by the Samba server, it produces a heap overflow. This update adds support to Mac OSX 10.6.0 to 10.6.7 ( Server and not server versions ). Besides, this update improves the exploitation by reverting the Samba server impersonation and installing an agent with root privileges in all Mac OSX supported versions.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2012-1182
Product Version: 
2013_R2
Released Date: 
Friday, November 22, 2013 - 00:00