Adobe Flash Player Arguments Indexing Exploit

Flash Player is prone to a memory corruption vulnerability that is caused by the lack of bounds-checking when indexing the arguments of a function. This can be exploited to execute arbitrary code by enticing an unsuspecting user to visit a malicious Web page containing a specially crafted SWF file. This exploit bypasses ASLR and DEP in order to deploy an agent.
Exploit type: 
Platform: 
Vulnerabilty ID: 
CVE-2011-2110
Product Version: 
11.0
Released Date: 
Wednesday, July 6, 2011 - 00:00